Jump to content
Search In
  • More options...
Find results that contain...
Find results in...



#0
Guest

User Menu


Sign In

Sign In



Sign Up

Forum Menu


Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

  • 0
Sign in to follow this  
Ultarg

Help with compile

Question

T
O
P
I
C

S
T
A
R
T
E
R

Hello Mmo-society

Here I am again asking for help, im trying to compile a sunwell core (https://github.com/Bloodication/335source)  in my debian 9 vps, everything goes fine in cmake, but when i want to compile i get this error.

/usr/bin/ld: /usr/local/lib/libcrypto.a(dso_dlfcn.o): undefined reference to sym                                                                                        bol '[email protected]@GLIBC_2.2.5'
//lib/x86_64-linux-gnu/libdl.so.2: error adding symbols: DSO missing from comman                                                                                        d line
clang: error: linker command failed with exit code 1 (use -v to see invocation)
src/server/authserver/CMakeFiles/authserver.dir/build.make:236: recipe for targe                                                                                        t 'src/server/authserver/authserver' failed
make[2]: *** [src/server/authserver/authserver] Error 1
CMakeFiles/Makefile2:1188: recipe for target 'src/server/authserver/CMakeFiles/a                                                                                        uthserver.dir/all' failed
make[1]: *** [src/server/authserver/CMakeFiles/authserver.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....

how can i fix it?

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1

This is something with your OpenSSL I believe. 

I was able to download, run cmake and make 
 

[100%] Linking CXX executable worldserver
../../../dep/lualib/liblualib.a(loslib.c.o): In function `os_tmpname':
/home/wserv/repo/bloodication/dep/lualib/loslib.c:(.text+0x86d): warning: the use of `tmpnam' is dangerous, better use `mkstemp'
[100%] Built target worldserver

the warning you see is common and does not impact the build. I would recommend following the guidance provided by TrinityCore 
 

Share this post


Link to post
Share on other sites
  • 0
SUPPORT STATUS - PENDING "Ride the wave of creativity"
Greetings, your support thread is currently pending and is awaiting response by a member of our staff team. In the mean time we encourage community submissions! Otherwise a team member will connect with you shortly.

Share this post


Link to post
Share on other sites
T
O
P
I
C

S
T
A
R
T
E
R
  • 0

yes you were right, for some reason i had to use openssl 1.0.0. and i was using 1.1

Share this post


Link to post
Share on other sites
  • 0

The question(s) in this support topic have been answered and the topic author has resolved their issue. This topic is now closed. If you have other questions, please open a new topic.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

About Us

MMO-Society is the Forum former known as Lordcraft, MMO-Society offers various of Resources to help you evolve your knowledge within Emulation, In the process we make sure to form a strong community bond in-between each other and thus we are proud to can admit that MMO-Society is possibly the friendliest Community Forum to currently exist.

All trademarks referenced are the properties of their respective owners.
©2018 MMO-Society. All rights reserved.

Social Links

Discord Server Join
Twitter Follow us
×
×
  • Create New...