Jump to content
Sign in to follow this  
Rusty

[[Template core/front/global/prefix is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]] Enabling Lua (.lua) plugin support

Recommended Posts

While Lua support is no longer supported by Oxide for public plugins submitted on our site, you can still install the Lua extension for Oxide to enable .lua plugins written in Lua if your host allows it.

  1. Download the Oxide.Core.Lua.dll extension from Bintray.com
  2. Download the dependencies for the extension from our GitHub repo
  3. Completely shutdown the server so that it is no longer running in order to replace any existing files
  4. Move/upload the files you downloaded to the location where the rest of Oxide's files are installed at
  5. Startup the server and you're good to go! To install .lua plugins, simply place them under oxide/plugins


Lua is no longer bundled in each Oxide build due to there not being enough interest and dedicated support for the language since C# replaced it as the primary language for public Oxide plugins. There are not many public plugins written in Lua remaining, but the extension will be maintained as necessary for basic plugin functionality.

Credits: Wulf

Share this post


Link to post
Share on other sites
Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...